With today’s production release, we’ve implemented several enhancements aimed at improving performance—specifically addressing slow response times on the Employee List. We’re pleased to report significantly faster load times as a result.
Here’s a summary of the key updates:
- Implemented infinite scroll on the Employee List to enhance performance
- Changed the default sort order to "employee create date" for faster loading
- Modified the Employee List to exclude records where all associated process flows have been archived
We’re excited about the improvements and hope they make for a smoother, more efficient experience. As always, please don’t hesitate to reach out if you have any questions or feedback by contacting our support team at support@clickboarding.com or (855) 283-5583.
Thank you, The Click Boarding Team
Posted Apr 15, 2025 - 14:25 CDT
Update
Hello,
We have identified an issue that is causing undue load on our reporting processes when retrieving records in the employee list within the new Admin UI. Our development team is actively working on a fix to improve load times. We will communicate further details once the fix is available, either through a hotfix or as part of our next release.
In the meantime, if needed, users can revert to the old Admin UI by following these steps:
- Navigate to the Action Center (house icon in the menu).
- Click on the "Old Admin UI" link.
If you have any specific questions or concerns, please don’t hesitate to contact our support team at support@clickboarding.com or (855) 283-5583.
Thank you for your understanding.
Best regards, The Click Boarding Team
Posted Apr 03, 2025 - 16:04 CDT
Monitoring
Hello,
Our Development team has implemented a temporary hotfix that allows you to revert to the "Old Admin UI" within your Admin site. To access this option:
- Navigate to the Action Center (house icon in the menu).
- Click on the "Old Admin UI" link.
Using the Old Admin UI will help alleviate the slow response times and degraded performance currently affecting the New Admin UI. In the meantime, our Development team is actively working on a permanent fix to restore the New Admin UI to full functionality. We hope to have this solution available soon.
We truly appreciate your patience and cooperation as we worked to implement this temporary fix.
If you have any specific questions or concerns, please contact our support team at support@clickboarding.com or (855) 283-5583.
Thank you, The Click Boarding Team
Posted Apr 02, 2025 - 15:41 CDT
Update
Hello,
First, we sincerely appreciate your continued patience as our Development team works to resolve this issue. Currently, the team is preparing a hotfix that they aim to implement later today. However, the exact ETA is still being determined. We will continue to keep you updated as we make progress.
If you have any specific questions or concerns, please contact our support team at support@clickboarding.com or (855) 283-5583.
Thank you, The Click Boarding Team
Posted Apr 02, 2025 - 14:03 CDT
Investigating
Hello,
Click Boarding is currently experiencing intermittent system-wide issues in our Production environment, specifically related to slow response times and degraded performance within your Admin Site. While we work to resolve this issue, you may encounter:
- Delays or restricted functionality for team members with lower permission levels (e.g., Limited, Task Only, Limited Assign Only).
- Slow, inconsistent, or missing search results
- General slow response times across the system.
We apologize for any inconvenience this may cause and appreciate your patience as we work toward a resolution. We will continue to provide updates as we investigate further.
If you have any specific questions or concerns, please contact our support team at support@clickboarding.com or (855) 283-5583.
Thank you, The Click Boarding Team
Posted Apr 02, 2025 - 09:31 CDT
This incident affected: Admin Site (clickboarding.com).